Browse By

Pré-requisitos “check” com oracle-rdbms-server-11gR2-preinstall

Olá,

Criei esse post para mostrar rapidamente uma evolução do pacote oracle-validate. Alguns amigos comentam até hoje que não encontraram nada parecido ao que o oracle-validate fazia (checagem e configuração de pre-requisitos nas versões OEL 5) na versão OEL 6  em diante mas, existe. O nome mudou para oracle-rdbms-server-11gR2-preinstall para versões R2.

Sua instalação é tão basica quanto ao oracle-validate, onde ele mesmo faz todas as configurações necessárias para o ambiente, como por exemplo: criação do usuário oracle, instalação e atualização dos pacotes necessários para a instalação do software database que faltam no SO, configurações dos arquivos do linux como sysctl, limit.conf e etc.

Após sua instalação é necessário fazer mais 2 processos e pronto, só executar o runInstaller (tanto em modo gráfico quanto em texto) que tudo irá funcionar. Vamos lá…

1: Entre no diretório do repositório do OEL 6 ( /etc/yum.repos.d )

2: Faça o download do repositório mais atual com o comando:

wget http://public-yum.oracle.com/public-yum-ol6.repo

Como mostrado acima, um arquivo chamado public-yum-ol6.repo foi baixado, edit o arquivo com o vi por exemplo e mude o parametro enable de 0 para 1 sobre o update que voce deseja baixar o repositório. Até agora a versão do Oracle Enterprise Linux homologada para a instalação da ultima versão do Software Oracle (11.0.2.3) seria a 6.1 e 6.2 recentemente.

Após feito isso, o ultimo comando necessário para executar todas as instalações seria: yum install oracle-rdbms-server-11gR2-preinstall

Veja abaixo que após esse comando só é necessário confirmar com Y ou N as modificações, no caso Y.

YES:

COMPLETE!!!

Veja abaixo uma pequena checagem do SO mostrando as configurações realizadas sobre um sistema operacional que estava”cru” (havia acabado de ser instalado).

Após isso é necessário configurar privilégios de pastas/diretórios e .bash_profile para o user oracle.

Executei uma instalação para mostrar que não houve erros na checagem de pré-requisitos do Software Oracle Database 11.2

DICA:  Uma das configurações desse pacote pelo que percebi, foi a criação de mais uma referência no GRUB para carregar (outra) configuração/iso do SO. No meu ambiente existia apenas uma referência com a configuração do RDAC e após a instalação desse pacote, foi criada outra onde no reboot do SO o mesmo utilizava essa nova referência no startup gerando alguns problemas, erros de IO e etc. O processo para resolver esse problema é simples, só é necessário editar o arquivo /etc/grup.conf e comentar as novas referências que o pacote adicionou.  Esse pacote também cria o serviço oracle-rdbms-server-11gR2-preinstall-firstboot que eu deixei desabilitado.

Forte abraço

3 thoughts on “Pré-requisitos “check” com oracle-rdbms-server-11gR2-preinstall”

  1. Pingback: Pré-requisitos “check” – Atualização 12cR1 | Wellington Prado – Oracle Blog
  2. Trackback: Pré-requisitos “check” – Atualização 12cR1 | Wellington Prado – Oracle Blog
  3. Hugo says:

    Opa, estou começando agora com oracle e com ctz isso será bem útil! Valeu.. :)

Leave a Reply

Your email address will not be published. Required fields are marked *